自己診断結果で異常



  • 以下自己診断結果なのですが、最終行で異常ありとの表示が出ました。
    今回初めての実施なので最初からなのか途中からなのかは不明です。
    サーボで全12Pin使用しているのですが、特に異常動作は確認できません。
    対処方法を教えて下さい。

    5V pushpull low io0 0 v (0 ~ 0.5)
    5V pushpull low io1 0 v (0 ~ 0.5)
    5V pushpull low io2 0 v (0 ~ 0.5)
    5V pushpull low io3 0 v (0 ~ 0.5)
    5V pushpull low io4 0 v (0 ~ 0.5)
    5V pushpull low io5 0 v (0 ~ 0.5)
    5V pushpull low io6 0 v (0 ~ 0.5)
    5V pushpull low io7 0 v (0 ~ 0.5)
    5V pushpull low io8 0 v (0 ~ 0.5)
    5V pushpull low io9 0 v (0 ~ 0.5)
    5V pushpull low io10 0 v (0 ~ 0.5)
    5V pushpull low io11 0 v (0 ~ 0.5)
    5V pushpull high io0 4.98 v (4 ~ 5.5)
    5V pushpull high io1 4.97 v (4 ~ 5.5)
    5V pushpull high io2 4.95 v (4 ~ 5.5)
    5V pushpull high io3 4.97 v (4 ~ 5.5)
    5V pushpull high io4 4.96 v (4 ~ 5.5)
    5V pushpull high io5 4.97 v (4 ~ 5.5)
    5V pushpull high io6 4.97 v (4 ~ 5.5)
    5V pushpull high io7 4.96 v (4 ~ 5.5)
    5V pushpull high io8 4.97 v (4 ~ 5.5)
    5V pushpull high io9 4.97 v (4 ~ 5.5)
    5V pushpull high io10 4.97 v (4 ~ 5.5)
    5V pushpull high io11 4.97 v (4 ~ 5.5)
    3V pushpull low io0 0 v (0 ~ 0.5)
    3V pushpull low io1 0 v (0 ~ 0.5)
    3V pushpull low io2 0 v (0 ~ 0.5)
    3V pushpull low io3 0 v (0 ~ 0.5)
    3V pushpull low io4 0 v (0 ~ 0.5)
    3V pushpull low io5 0 v (0 ~ 0.5)
    3V pushpull low io6 0 v (0 ~ 0.5)
    3V pushpull low io7 0 v (0 ~ 0.5)
    3V pushpull low io8 0 v (0 ~ 0.5)
    3V pushpull low io9 0 v (0 ~ 0.5)
    3V pushpull low io10 0 v (0 ~ 0.5)
    3V pushpull low io11 0 v (0 ~ 0.5)
    3V pushpull high io0 3.09 v (2.5 ~ 3.5)
    3V pushpull high io1 3.03 v (2.5 ~ 3.5)
    3V pushpull high io2 1.98 v (2.5 ~ 3.5)
    3V pushpull high io3 3.01 v (2.5 ~ 3.5)
    3V pushpull high io4 3.01 v (2.5 ~ 3.5)
    3V pushpull high io5 3.03 v (2.5 ~ 3.5)
    3V pushpull high io6 3.02 v (2.5 ~ 3.5)
    3V pushpull high io7 3.02 v (2.5 ~ 3.5)
    3V pushpull high io8 3.04 v (2.5 ~ 3.5)
    3V pushpull high io9 3.03 v (2.5 ~ 3.5)
    3V pushpull high io10 3.01 v (2.5 ~ 3.5)
    3V pushpull high io11 3.02 v (2.5 ~ 3.5)
    open-drain 5v pull-up high io0 4.38 v (4 ~ 5.5)
    open-drain 5v pull-up high io1 4.33 v (4 ~ 5.5)
    open-drain 5v pull-up high io2 0.37 v (4 ~ 5.5)
    open-drain 5v pull-up high io3 4.31 v (4 ~ 5.5)
    open-drain 5v pull-up high io4 4.35 v (4 ~ 5.5)
    open-drain 5v pull-up high io5 4.34 v (4 ~ 5.5)
    open-drain 5v pull-up high io6 4.36 v (4 ~ 5.5)
    open-drain 5v pull-up high io7 4.33 v (4 ~ 5.5)
    open-drain 5v pull-up high io8 4.37 v (4 ~ 5.5)
    open-drain 5v pull-up high io9 4.33 v (4 ~ 5.5)
    open-drain 5v pull-up high io10 4.37 v (4 ~ 5.5)
    open-drain 5v pull-up high io11 4.34 v (4 ~ 5.5)
    open-drain 3v pull-up high io0 3.09 v (2.5 ~ 3.5)
    open-drain 3v pull-up high io1 3.02 v (2.5 ~ 3.5)
    open-drain 3v pull-up high io2 0.05 v (2.5 ~ 3.5)
    open-drain 3v pull-up high io3 3.02 v (2.5 ~ 3.5)
    open-drain 3v pull-up high io4 3.02 v (2.5 ~ 3.5)
    open-drain 3v pull-up high io5 3.03 v (2.5 ~ 3.5)
    open-drain 3v pull-up high io6 3.02 v (2.5 ~ 3.5)
    open-drain 3v pull-up high io7 3.03 v (2.5 ~ 3.5)
    open-drain 3v pull-up high io8 3.04 v (2.5 ~ 3.5)
    open-drain 3v pull-up high io9 3.04 v (2.5 ~ 3.5)
    open-drain 3v pull-up high io10 3.01 v (2.5 ~ 3.5)
    open-drain 3v pull-up high io11 3.01 v (2.5 ~ 3.5)
    次の番号のioに異常があります io2



  • @Google-Homer テスト結果ありがとうございます。みたところモータードライバーには問題がなく5vで使う分にはio2は問題なく使用できそうです。3vプッシュプルやオープンドレインとして使用する時に正しく使えない可能性があります。
    io2に何もつながっておらず、何度やっても同じエラーであればio2のモータードライバー以外の回路が物理的に破損した可能性が高いです。

    サーボモーターなどを駆動される分には影響がなく、io2以外は今までどおりなので3vやオープンドレインとして利用していただけます。



  • 了解しました。後で、未接続状態で何度か試してみます。


Log in to reply
 

SUGGESTED TOPICS