M5StackBasicで試したら警告が出ました。



  • Re: Scroll Displayクラス

    はじめまして。
    ObnizOS(ver 3.4.2)を搭載したM5StackBasicで試したところ、以下の警告が出ました。また、スクロールもうまく表示されませんでした。
    Warning: Update obniz.js 3.0.0 or higher to control obnizOS 3.4.2. see https://obniz.com/doc/cloud_device/ota

    どのような対処をすれば、よいのでしょうか?



  • @Inventor-84
    Scroll DisplayクラスのトピックにReplyの形で投稿したかったのですが。。。
    初めてなので、失敗してしまいました。
    ご容赦ください。
    よろしくお願いいたします。



  • @Inventor-84 はじめまして。

    使われているobniz.jsのバージョンが古いようです。
    obniz.jsはGitHubで公開されている弊社のオープンソースでobnizに接続して操作するためのSDKです。
    https://github.com/obniz/obniz/releases
    OSよりも新しいことが求められます(特にOS3系ならsdkも3系が求められます)

    現在はHTMLとJavaScriptで使われているのでしょうか。
    その場合は

    <script src="https://unpkg.com/obniz@3.x/obniz.js"></script>
    

    とobniz.jsを読み込んでる部分を書き換えて頂ければ3系の最新が取り込まれるため警告は出なくなります。

    Nodejsの場合はnpmより最新のものを取り込んでください。

    2系から3系にはBLE周りのみbreaking changeがあります。
    BLEを使っていない限りはプログラムを変えなくても同じ動きとなります。


Log in to reply
 

SUGGESTED TOPICS