ArduCAM-Mini-2MP-Plusのサンプルコードを動かすとエラーが出る



  • こんにちは。

    JSパーツライブラリにある「ArduCAM-Mini-2MP-Plus」を購入し起動確認をしております。

    コードを実行してみると、コンソールに「Error: unknown chip 9793」と表示されます。
    この回避策がありましたらご教授願いたいです。
    次のコードで確認しています。

    <!-- HTML Example -->
    <html>
    <head>
    <meta charset="utf-8">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <script src="https://obniz.io/js/jquery-3.2.1.min.js"></script>
    <script src="https://unpkg.com/obniz@latest/obniz.js"></script>
    </head>
    <body>
    
    <div id="obniz-debug"></div>
    <img id="image">
    
    <script>
    var obniz = new Obniz("OBNIZ_ID");
    obniz.onconnect = async function () {
      obniz.io11.output(true);
      var cam = obniz.wired("ArduCAMMini", { cs:0, mosi:1, miso:2, sclk:3, gnd:4, vcc:5, sda:6, scl:7, spi_frequency:1000000, spi_drive:"5v",module_version:1 });
      await cam.startupWait();
      const data = await cam.takeWait('1024x768');
      console.log("image size = " + data.length + " bytes");
    
      const base64 = cam.arrayToBase64(data);
      document.getElementById("image").src = "data:image/jpeg;base64, " + base64;
    }
    </script>
    </body>
    </html>
    


  • @まえぷー さん

    arducamのバージョンの違いによるエラーが出ているようです。

    arducamにはOV2640が搭載されているのですが、
    OV2640のchipIDが9794(0x2642)と9793(0x2641)に2種類あるようです。

    obniz.jsがchipIDが9794(0x2642)のものにしか対応していませんでしたので、
    次回のobniz.jsのアップデートにて対応したいと思います。



  • お忙しいところご確認下さり、ありがとうございます。
    アップデート待ってます(^^)



  • @まえぷー さん

    今週リリースしたobniz.js v2.5.0でおそらく対応できたと思いますのでお試しください


Log in to reply
 

SUGGESTED TOPICS

  • 4
  • 1
  • 2
  • 2
  • 2
  • 6
  • 2
  • 2